× Forum for the GPXTrackMap Content Plugin for Joomla! 2.5 and 3.x

Missing Graphics in the map

fingeradmin replied the topic: Missing Graphics in the map

2 years 3 months ago

Hello Hartmut,

sorry, my fault - i just took the path from the error message,
but didn't realize that these are just the links Joomla generates.

You should put the img folder into the folder where your
OpenLayers.js is, i think that OpenLayers expects the
images in a subdirectory of the directory where it lies.
At least that's how it's working here...

cheers, Frank

Please Log in or Create an account to join the conversation.

Baeribeeri replied the topic: Missing Graphics in the map

2 years 3 months ago

Thank you for the download link. In your zip-file all graphics are included. Your suggestion was to put the img folder in the folder called aktuelles. In Joomla there is no folder called aktuelles. aktuelles is a category for a blog. So the question is: Where to put the img folder? Firebug in firefox says, that the images have to be in the folder img, but I can't find out, in which directory Jommla generates the HTML-documents. Any idea?

Have a nice weekend! Hartmut

Please Log in or Create an account to join the conversation.

fingeradmin replied the topic: Missing Graphics in the map

2 years 3 months ago

Hello Hartmut,

i have installed the OpenLayers 2 v2.12 version here locally to test with:

https://github.com/openlayers/openlayers/releases

In the ZIP file, the images are in the "img" subfolder.

cheers, Frank

Please Log in or Create an account to join the conversation.

Baeribeeri replied the topic: Missing Graphics in the map

2 years 3 months ago

Thanks for your help, but I can't find the images in the package OpenLayers V3.3.0. Is it the right package? Where can I get the correct package from?

Hartmut

Please Log in or Create an account to join the conversation.

fingeradmin replied the topic: Missing Graphics in the map

2 years 4 months ago

Hello Hartmut,

it is not enough to copy only the OpenLayers.js to your server. The full distribution also includes the symbols that go onto the map. If you visit your site with Chrome with Developer Tools (F12) enabled, it shows which graphics are missing.

If you unzip the full OpenLayers package, they are in the "img" subdirectory.

Just copy them over to your /aktuelles/img directory and they should work fine!

cheers, Frank

Attachments:

Please Log in or Create an account to join the conversation.

Baeribeeri created the topic: Missing Graphics in the map

2 years 4 months ago

in my new project with Joomla 3.3.6 I want to use maps for a large bicycle-tour. I had to copy the OpenLayers.js to my webspace to see the map. But all graphic Icons to scale and move the map are invisible. What can I do to see those graphics? Here is the link to one of the maps:

www.volmer2.de/index.php/aktuelles/5-von-herne-nach-venlo

Thank you for your help!
Hartmut

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum