× Forum for the GPXTrackMap Content Plugin for Joomla! 2.5 and 3.x

Googlemap Physisch & Hybrid lädt nicht

Mr. Svonda replied the topic: Googlemap Physisch & Hybrid lädt nicht

1 year 8 months ago

hallo Frank

ich habe dir zu danken, für den super support *thumbsup*

jetzt funktioniert wieder alles tiptop :)
gerade bei tracks in den alpen, ist das physische layer einfach am übersichtlichsten.

liebe grüsse
sven

Please Log in or Create an account to join the conversation.

fingeradmin replied the topic: Googlemap Physisch & Hybrid lädt nicht

1 year 8 months ago

Hallo Sven,

verdammt - war mir nicht aufgefallen!

Aber auch das ist lösbar: Lade Dir die "Vollversion"
von OpenLayers 2.13 herunter, die gibt es hier.

Aus dem ZIP lädst Du die Verzeichnisse "img" und "theme"
auf Deinem Server in den Ordner /plugins/content/gpxtrackmap.

Dann sollten alle Bedienelemente wieder da sein - wenn
man das OpenLayers-Script auf dem eigenen Server hat,
sucht es auch da nach den Grafiken für die Zoom-Elemente
und nach der dazugehörigen CSS-Datei...

Danke nochmals!

lg, Frank

Last Edit: 1 year 8 months ago by fingeradmin.
The following user(s) said Thank You: Mr. Svonda

Please Log in or Create an account to join the conversation.

Mr. Svonda replied the topic: Googlemap Physisch & Hybrid lädt nicht

1 year 8 months ago

hey cool, merci ! B)

physisches und hybridlayer funktionieren wieder ... aber leider werden mit der gepatchten version die kartenbedienelemente (zoom, kartenauswahl ...) jetzt nicht mehr angezeigt :(

liebe grüsse
sven

Please Log in or Create an account to join the conversation.

fingeradmin replied the topic: Googlemap Physisch & Hybrid lädt nicht

1 year 8 months ago

Hallo Sven,

danke für den Link! Die Lösung steht schon quasi da:

Das OpenLayers-Script funktioniert mit der Google Maps-API wohl
nicht mehr richtig. Auf der Seite ist aber eine gepatchte Version
von einem FredC verlinkt, mit der auch der Hybrid-Layer wieder
funktioniert:

OpenLayers2.13.2.full.js

Ich habe die Datei mal auf den Server hier geladen und in den Plugin-Optionen
(Erweiterte Einstellungen) den Pfad entspr. eingestellt:
OpenLayers script source: /plugins/content/gpxtrackmap/OpenLayers.2.13.2.full.js

Bitte beachten: das ist keine offizielle OpenLayers-Version,
es könnte also damit evt. andere Probleme geben, also
"use at your own risk" ;)

Die GoogleMaps-Layer scheinen damit jetzt jedenfalls
alle wieder zu funktionieren.

lg, Frank

Please Log in or Create an account to join the conversation.

Mr. Svonda replied the topic: Googlemap Physisch & Hybrid lädt nicht

1 year 8 months ago

hallo Frank

merci für die rückmeldung.

komisch war auch dass zuerst die physische karte nicht mehr funktionierte, ich hatte dann die standardkarte auf hybrid umgestellt und ein paar tage später funktionierte auch diese nicht mehr. habe jetzt auf der produktiven seite halt die mapnik-karte als standard gesetzt.

verwendest du in deinem plugin irgendwie ein openlayers-javascript ?
habe da nämlich gerade etwas gefunden, wo ein sehr ähnliches problem beschrieben wird:
gis.stackexchange.com/questions/160444/g...e-layer-and-re-apply

vieleicht hilft es dir ja weiter, ich blick da leider zu wenig durch :unsure:

liebe grüsse
sven

The following user(s) said Thank You: fingeradmin

Please Log in or Create an account to join the conversation.

fingeradmin replied the topic: Googlemap Physisch & Hybrid lädt nicht

1 year 8 months ago

Hallo Sven,

nein, leider habe ich keine Ahnung was da schief läuft.

Ich habe mir auch schon einen API-Key besorgt und eingetragen,
damit funktioniert es hier auf der Seite aber auch nicht... :(

Das seltsame: In meiner lokalen Testumgebung (XAMPP) funktioniert
es ohne Probleme!

Es gibt auch in der Konsole von Chrome keinerlei Warnings oder
irgendwelche Fehlermeldungen... ich bin hier etwas ratlos...

lg, Frank

The following user(s) said Thank You: Mr. Svonda

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum