× Forum for the GPXTrackMap Content Plugin for Joomla! 2.5 and 3.x

If you have problems with GoogleMaps hybrid layer

fingeradmin created the topic: If you have problems with GoogleMaps hybrid layer

1 year 6 months ago

Hi there,

in a recent thread german user Sven noticed a problem with the
GoogleMaps hybrid layer when used with the plugin.

It appears there was a change in the Google maps API that stopped
the official version of OpenLayers from functioning with the
hybrid layer.

In a post on gis.stackexchange.com ,
FredC linked to a patched version of the OpenLayers script
that cures the problem. NOTE this is not an official
OpenLayers Release, but a patched file, so no guarantee
everything will work as expected! After doing some tests
i find it to work just fine, though.

If you need the hybrid layer, do the following:

- go to the patched OpenLayers file on Google Drive

- download the file (OpenLayers.2.13.2.full.js,
there's a download link in the center of the header bar)

- upload it to your server into the directory
/plugins/content/gpxtrackmap/

- then go to the plugin options in Joomla, go to
the Advanced Settings tab and change the
"OpenLayers script source" setting to:

/plugins/content/gpxtrackmap/OpenLayers.2.13.2.full.js

...and, of course, Save the settings.
All GoogleMaps should now work again as expected.

Thanks to Sven for pointing this out!

EDIT: if you do this (hosting the OpenLayers script
on your own server), you will need to also supply
the graphical elements for zooming and panning on
your server.

To do this, you need to download the "full" version
of OpenLayers 2.13 here.

From the ZIP file, upload the folders "img" and "theme"
to your server into the above mentioned folder:
/plugins/content/gpxtrackmap/

Thanks once more to Sven for bringing this to my attention!

cheers, Frank

Last Edit: 1 year 6 months ago by fingeradmin.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum