× Forum for the GPXTrackMap Content Plugin for Joomla! 2.5 and 3.x

API key required

fingeradmin replied the topic: API key required

1 month 2 weeks ago

Hello Frank,

the easiest way to track down that sort of problems is to visit your page with Chrome or Firefox with Developer Tools enabled (hit F12, then reload the page).

There's a Console output in that window that will show you any error messages that occurred while loading the page.

Take a screenshot of those messages and post them here, i'll have a look then.
OR, if your server is accessible from the web, post the URL to the page with the map here and i'll have a look myself.

cheers, Frank

Please Log in or Create an account to join the conversation.

hobbykochma@web.de replied the topic: API key required

1 month 2 weeks ago

Hello Frank,

Thanks for your quick reply. I tried your approach.

But after the implementation no map is been displayed:

View Attachment for more details. Any idea what could cause this?

Thanks for a hint.

Best Regards

Frank

Attachments:

Please Log in or Create an account to join the conversation.

fingeradmin replied the topic: API key required

1 month 3 weeks ago

Hi Tom,

i wasn't aware that one now needs API keys for that map layer, last time i
checked they worked fine without any keys. They must have changed that recently.

Anyway, after some googling, i think it is doable:

Edit the file i have attached and replace "<insert your api key here>"
with your api key. (You'll need to get that first from Thunderforest , obviously.)

Upload the file to your server into /plugins/content/gpxtrackmap.

In the Plugin options, set the map layer to "Custom Map Layer #3"
or, in the invocation code in your article, add ",maplayer=10"

That should do the trick - let me know how it goes, please!



P.S.: yo'll find some more info on Custom Map Layers here .

cheers, Frank

Last Edit: 1 month 2 weeks ago by fingeradmin.

Please Log in or Create an account to join the conversation.

tomphillipspcs created the topic: API key required

1 month 4 weeks ago

I am getting an overlaid warning on Open Street Map

www.w-o-w.com/activities/running/cairngorm-trail-running

API key required.

Any fix for this?

Tom

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum