× Forum for the GPXTrackMap Content Plugin for Joomla! 2.5 and 3.x

API key required

hobbykochma@web.de replied the topic: API key required

1 year 3 months ago

Hello Frank

MANY THANKS. With your new file it works perfectly :-).

Best Regards

Frank

Please Log in or Create an account to join the conversation.

fingeradmin replied the topic: API key required

1 year 3 months ago

Hi again Frank,

i've been fiddling with this for a couple of hours now, i got myself an API key of my own from Thunderforest to test with and i finally got it to work :woohoo:

It turned out there was a stupid mistake in the CustomMapLayer3.js that i posted earlier on: there were som "$" signs missing... :S

I have also removed the "http:" in front of the tile URLs, so it should work on http as well as https now.

Could you try again please with the attached version?
(you'll again have to edit the .js file and put in your own API key).

File Attachment:

File Name: CustomMapLayer3.zip
File Size:0 KB


I have made some "quick and dirty" modifications to the main script (gxtrackmap.php) to get the other Thunderforest map layers to work, as you can see here:
http://www.frankingermann.de/gtm.html

To get this to work cleanly for everybody, i need to introduce a new Plugin option (Thunderforest API key) in the next release, which is quite a bit of work.

So, for the moment, please use the workaround with the custom map layer.

Hope it works for you this time!

cheers, Frank

Attachments:

Please Log in or Create an account to join the conversation.

hobbykochma@web.de replied the topic: API key required

1 year 3 months ago

Hello Frank,

Maybe there is another approach. Can you kindly check the page: www.reisenhofer.de/index.php/de/fotos-de...ren-wir-unterwegs-10
On this page you see the same track, which is shown in a OpenStreet Map. One is working and one not.
Maybe this is related to a difference in the configuration of the plugin? What do you think?
Best Regards
Frank

Please Log in or Create an account to join the conversation.

fingeradmin replied the topic: API key required

1 year 3 months ago

Hi Frank,

yes, this looks like "yet another" http vs. https CORS issue:

Your site is running on http, while the tile servers on thunderforest.com apparently redirect even the plain http requests to an https server. Bummer.

The only "official" way to resolve this (that i know of!) is to run your site on https as well.
You should contact them directly and find out if there is another way
(a "simple http" way) to get access to the tiles.

Does this make anything "safer" than before? Imnsho: NO.

(we're talking about road trips here, right? Not about H-Bomb construction plans.
And who made this OSM map the best one on the planet?
Lots of girls and guys out there using "just" plain simple http (without the "s"!).
There's nothing to hide in a map, UNLESS you want to hide sthg. Sorry the rant ;) )

cheers, Frank

Please Log in or Create an account to join the conversation.

hobbykochma@web.de replied the topic: API key required

1 year 3 months ago

Hello Frank,

Looks like this is caused by a CORS issue, which was not existing before.

You can check this e.g. here: www.reisenhofer.de/index.php/de/fotos-de...ren-wir-unterwegs-10

Any idea how to solve this?

Best Regards

Frank

Please Log in or Create an account to join the conversation.

fingeradmin replied the topic: API key required

1 year 3 months ago

Hello Frank,

the easiest way to track down that sort of problems is to visit your page with Chrome or Firefox with Developer Tools enabled (hit F12, then reload the page).

There's a Console output in that window that will show you any error messages that occurred while loading the page.

Take a screenshot of those messages and post them here, i'll have a look then.
OR, if your server is accessible from the web, post the URL to the page with the map here and i'll have a look myself.

cheers, Frank

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum