× Forum for the GPXTrackMap Content Plugin for Joomla! 2.5 and 3.x

New Version 1.3.0 - jQuery issue, Translations(!)

fingeradmin replied the topic: New Version 1.3.0 - jQuery issue, Translations(!)

6 years 2 months ago

Hi Sergio,

yeah, i know, i'm a bit behind with a new "official" release.

Since version 1.2.0 i have improved quite a lot and also ironed out
some bugs... i will wait until the weekend, and if i don't get
new error messages i will put the new 1.3.1 version up as a new
release version. The new "Custom Map Layers" thing is really
quite nice - thanks to David from rando-lofoten.net
for helping me in getting this to work! (You should check out
this site, the Norwegian Mapping authority have a really nice
topographic map layer made available through OpenLayers.)


I guess there are quite some people using J3.2.x now, they should use
at least 1.3.0 because of the mootools/jQuery fix in there.
So, yes, a new "official" release is due.


cheers, Frank

Please Log in or Create an account to join the conversation.

sergio replied the topic: New Version 1.3.0 - jQuery issue, Translations(!)

6 years 2 months ago

Frank
with this version (1.3.1) all is OK !
I used the version that is in the "download" link (1.2.0)
thank you

Last edit: 6 years 2 months ago by sergio.

Please Log in or Create an account to join the conversation.

fingeradmin replied the topic: New Version 1.3.0 - jQuery issue, Translations(!)

6 years 2 months ago

Hi Sergio,

the latest version (1.3.0) WORKS - i have double-checked everything twice
now, and all i can say is that it works here.

There are only three places in the code that handle the Timeshift parameter,
and these are all completely unchanged since the 1.2.2 version.

It must be something else that's causing the problem for you...

could you please post:
- a screenshot of the plugin's parameters (Track information page)
- a screenshot of your Parameter Presets (if you are using any)
- a screenshot of the Article editor showing the Invocation code
(maybe there's some html in it that you don't see? So it's best
to have a screenshot with the WYSIWYG editor turned off.)

I'm sure we can solve this - it must be something stupid...

EDIT: in the other thread (Version 1.3.1) i uploaded a new version
that has the option to disable the warning messages. Please try that one!

cheers, Frank

Last edit: 6 years 2 months ago by fingeradmin.

Please Log in or Create an account to join the conversation.

sergio replied the topic: New Version 1.3.0 - jQuery issue, Translations(!)

6 years 2 months ago

Hey Frank
j'ai réinstallé cette version
software.frankingermann.de/media/kunena/...map_v1.2.2-beta1.zip
et plus aucune erreur
la version dans le menu "download" ne fonctionne pas
quelle est la dernière version qui fonctionne ?


Hey Frank
I reinstalled this release
software.frankingermann.de/media/kunena/...map_v1.2.2-beta1.zip
and no error !!!
the version in the "download" menu does not work
what is the last release that works?

Last edit: 6 years 2 months ago by sergio.

Please Log in or Create an account to join the conversation.

sergio replied the topic: New Version 1.3.0 - jQuery issue, Translations(!)

6 years 3 months ago

in my article
{gpxtrackmap}track.GPX,preset=tab1,titimeshift=1{/gpxtrackmap}

it worked and now this warning :-(


GPXTrackMap plugin warnings:
unknown parameter: "titimeshift"

article

would you have an old release to test if it works ?

Last edit: 6 years 2 months ago by sergio.

Please Log in or Create an account to join the conversation.

fingeradmin replied the topic: New Version 1.3.0 - jQuery issue, Translations(!)

6 years 3 months ago

Hi Sergio,

sorry, i can not reproduce this - i just tested setting the timeshift in
the plugin options, via a preset, as well as directly in the invocation code.
It all works here as expected, UNLESS i mis-spell "titimeshift" like
"ti-timeshift", then i get the warning you see.

Can you double-check that you have the spelling right? Maybe you have an
"i" with an accent in there...?

FYI: what you see is not an error, it is a warning. It means that you have
a parameter in either a Parameter Preset or the invocation code itself
that the plugin can not handle. I have built this double-check so that
you will be made aware of spelling errors in parameter names, rather
than wondering why the parameter is not working...

cheers, Frank

Last edit: 6 years 3 months ago by fingeradmin.

Please Log in or Create an account to join the conversation.

Powered by Kunena Forum